
1 

Appendix 6  
GIS Analysis 

 
Data preparation (JH) 
 
The spatial assessment of biodiversity benefits was performed using ArcView 3.2 
GIS. ArcView was used rather than ArcGIS owing to its broader user-base and the 
fact that the Patch Analyst extension is currently only available for ArcView.  
 
Input GIS layers: 
 

• Mapped onground works in various projections (AGD1996 /Vicmap) 
• Vegetation layer 
• Aerial photography or Landsat image (optional) 
• Roads, town, watercourses used for the locator map. 

 
The aerial photography can be used to help interpret the maps of vegetation and 
onground works.  If the onground works were partially, or not attributed, approximate 
assumptions of the actions (either remnant protection or revegetation) could be made.  
Polygons, which overlayed more than 50 % of a remnant, were classified as remnant 
protection along with those classified in the database, and those identified on the 
satellite or aerial photography as being over unmapped remnants e.g. riparian 
vegetation. Further classification into more refined categories such as remnant 
enlargement, remnant enhancement, revegetation for erosion or riparian restoration 
could be made with more time and local knowledge.   
 
The change in vegetative cover over the subcatchment was based on an initial merged 
layer of existing vegetation (before) then enlarged by a layer of all onground works 
which occurred outside the existing vegetation layer (after).  This included proposed 
works and eliminated instances when works intersected (e.g. revegetation occurring in 
a remnant protection block or completed works over proposed polygon). 
 
Patch Analyst for ArcView (AZ) 
1. Introduction 

Patch Analyst is a freely available suite of extensions for ArcView GIS which allows 
users to spatially analyse landscapes. It focuses on landscape spatial metrics such as 
connectivity, nearest neighbour analysis, edge-area ratios, contiguity and other 
indices. Patch Analyst is available for raster and vector data models (GRIDS and 
Shapefiles) with the raster version using the algorithms developed for Fragstats, the 
stand-alone landscape analysis software. Patch Analyst can be downloaded from 
http://flash.lakeheadu.ca/~rrempel/patch/ and requires ArcView GIS. To use the Patch 
Grid option in Patch Analyst, ArcView Spatial Analyst is required and all data must 
be converted to raster format (GRID format). The raster version of Patch Analyst 
offers a number of additional landscape indices not available in the vector version. 
Foremost of these indices is nearest neighbour analysis, core area analysis and some 
additional diversity and interspersion metrics. 
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Patch Analyst adopts a hierarchy of analysis based on the concept of landscapes, 
classes and patches and allows users to derive metrics for either of these. A landscape 
includes all the patches, classes and polygons in a study area. A class includes all 
patches, polygons, contiguous cells or shapes in a theme or landscape that have the 
same value for a given attribute. Each individual polygon or contiguous set of 
identical grid cells is a patch. Each patch has a separate record, or row, in the theme 
attribute table (or grid value) (Patch Analyst Help File, 2003). 

2. Performing an Analysis 

The following example assumes that Patch Analyst extension has been installed 
correctly and enabled (Figure 1 and instructions available at  
http://flash.lakeheadu.ca/~rrempel/patch/) and that Spatial Analyst is installed. The 
example focuses on the derivation of the nearest neighbour index for a landscape 
containing newly revegetated patches. The nearest neighbour index provides an 
estimate of the connectivity inherent in the landscape. Users are encouraged to 
explore the suite of other landscape indices available in Patch Analyst as they may 
have more relevance for their case study.  

 

Figure 1. Enabling the Patch Analyst Extension in ArcView 

Figure 2 shows the ArcView interface and the PatchGrid drop-down menu being used 
to perform an analysis. In this simple example we will extract the nearest-neighbour 
index for this hypothetical landscape. The example data is in ArcView GRID format. 
From the PatchGrid menu select Spatial Statistics (PatchGrid>Spatial Statistics).  

Figure 3 shows the Patch Analyst interface for selecting landscape metrics for 
analysis. In our case study we will calculate the Mean Nearest Neighbour Distance, 
Number of Patches, Mean Patch Size, Total Edge and some Diversity and 
Interspersion metrics. Our analysis will be at the Landscape level as our data shows 
either vegetated or non-vegetated patches. In some instances, for example when 
dominant species information is available for each patch, a Class level analysis may 
be appropriate.  



3 

 

Figure 2.  ArcView window showing an example raster data set 
of newly revegetated landscape in raster format 
(GRID). The drop-down menu shows the PatchGrid 
interface for calculating spatial indices for raster data.  

Results from a Patch Analyst analysis are written to an ArcView table and appear as 
those shown in Figure 4. The Patch Analyst help file will be required to interpret the 
column headings. In the analysis conducted, we can see that our hypothetical 
landscape has an inter-patch mean nearest neighbour distance of 183.00 metres, it 
contains 1197 contiguous patches and the mean patch size is 250.68 metres. Users are 
encouraged to explore the suite of Patch Analyst options available and begin 
comparing statistics for different landscapes, classes or for different landscape 
management scenarios.  
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Figure 3.  Patch Analyst interface for selecting landscape metrics 
for analysis  

Figure 4.  Patch Analyst interface for selecting landscape metrics for 
analysis  

Notes: 

• As Patch Analyst calculates distance metrics, it is critical that the correct map 
units are firstly defined in ArcView (View>Properties). Failing to do so will 
result in erroneous Patch Analysis indices. 

 
Distance to Core measurements (JH) 
 
Core areas of greater than 10 ha were extracted from the existing vegetation layer and 
saved as a new dataset.  This dataset (currently a vector Shapefile) was converted to a 
raster data model (GRID format). Using the Spatial Analyst ‘Find Distance’ function, 
a distance to core areas raster was produced showing concentric circles of distance 
intervals around each core area.     
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To calculate the ‘before’ distance to core, all the remnants less that 10 ha were 
assigned latitude and longitude centroids using an Avenue script (addxy.ave) (see 
appendix) that adds coordinates to the Shapefile attribute table.  This enable the 
‘remnant bits’ to be added to the View as an ArcView ‘Event Theme’ showing the 
centroid of each remnant as a point data model. An Avenue script called 
Interpolate.ave (see appendix) was run to extract the distance to the core area for each 
remnant centroid. Distances are added to the centroids attribute table and show the 
distance in meters to each core area. Calculating the mean of these distances provides 
a mean distance to core area before onground works commenced. 
 
To calculate the ‘after’ distance, onground works were merged with the ‘remnant 
bits’, converted to points and placed on the ‘distance to core area’ surface.  The 
average of the distance measurements produced by the Interpolate.ave script became 
the mean distance to core area after onground works.   
 
Developing And Analysing A Patch Distance Matrix (AZ) 
 
 (This is used for calculating the mean distance to the 5 nearest neighbours. As the 
excel steps are restricted to 256 columns it needs to be carried out on a sub sample of 
remnant patches. The calculation was carried out for Saltshaker but it was considered 
too time consuming to be applied to sub-samples from other projects) 

This document describes the use of ArcView GIS and Microsoft Excel for generating 
simple measures for assessing changes to landscapes. In this first component, we 
introduce the use of the distance measures to assess average inter-patch distances. For 
this analysis we will utilise two publicly available extensions/scripts for ArcView, and 
an Excel Macro to format and analyse our distance file: 

• Dmatrix_en.avx –  a publicly available ArcView extension for creating a 
distance matrix 

• Addxy.ave – An Avenue script that adds latitude and longitude coordinates to 
a Shapefile. 

• Distancematric.vba – A Visual Basic macro that processes a distance matrix 
into a format for statistical analysis using histograms. 

1. Using Arcview To Create An Inter-Point Distance Matrix 
a. The first stage of the process is to convert all the polygons to points 

showing the centroid of each polygon. All proceeding analysis is 
performed on point features. 

b. Add the Shapefile containing polygons that define each vegetation 
patch. 

c. Load the script called AddXY.ave to ArcView and run this script using 
the vegetation patch file as the input. This will add two new columns to 
the attribute table of the polygon shapefile called X-coord, and Y-
coord. 

d. These coordinates will be used to create a new Shapefile containing 
point features using the View>Add Event Theme option. Select this 
option from the menu and fill in the appropriate options as shown 
below. 
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e. A new theme will be added to the ArcView view called ‘Attributes of 
Vegetation Patches.shp’ or some other similar name depending on the 
naming convention of your files. This file needs to be written to a 
permanent Shapefile by selecting Theme>Convert to Shapefile and 
added to the view. 

f. We can now start creating a distance matrix to show the distance from 
each patch to every other patch. 

g. The purpose of using the “dmatrix_en.avx” ArcView extension is to 
calculate the distance between the set of points presented in one theme 
in the ArcView View and create a matrix embedding the distance 
values between these points.  For instance, if the theme has 5 points, 
the output distance matrix will take the form: 

 
 

 

 

 

h. Copy the “dmatrix_en.avx” extension to the EXT32 folder of your 
ArcView program.  To run the extension use the following command:  
File >Extensions.  The extension box will appear on your screen.  
Scroll down until you locate the extension “Distance Matrix of Point 
Features”.  Check that extension then click OK.   

IDs Point1_ID Point2_ID Point3_ID Point4_ID Point5_ID 
Point1_ID 0 Dist. 1 2 Dist. 1 3  Dist. 1 4 Dist. 1 5 
Point2_ID Dist. 2 1 0 Dist. 2 3 Dist. 2 4 Dist. 2 5 
Point3_ID Dist. 3 1 Dist. 3 2 0 Dist. 3 4  Dist. 3 5 
Point4_ID Dist. 4 1 Dist. 4 2 Dist. 4 3 0 Dist. 4 5 
Point5_ID Dist. 5 1 Dist. 5 2 Dist. 5 3 Dist. 5 4 0 
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i. In your View window a new button  will appear in the button bar.  
This button will enable you to create the distance matrix, however 
some formatting is required before we generate our distance matrix. 

j. A few things need to be in place before you can run this extension.  

i. Firstly, set the View units to the appropriate unit 
(View>Properties). 

ii. A string type field must exist that provides a unique ID for each 
point in the Shapefile. These unique values will be used to 
identify the column and row headings of the distance matrix. 

iii. Most unique feature identifiers in a Shapefile will be of 
numeric format hence we need to convert this to a string field. 

iv. Create a new field in the table, defined as a string and call it 
something logical such as UniqueID. 

 

 
 

v. Highlight this field, and using the Field Calculator 
(Field>Calculate), perform the following calculation which 
populates the new field with a String type containing a unique 
ID for each point. 

 

 

 



8 

 
 

vi. The data is now ready to be converted to a distance matrix. 

k. We will now create our distance matrix by selecting the  button 

l. As the input, select the Shapefile that contains the new unique feature 
identifier and latitude and longitude. 

 

 
 

m. Select the field containing the new String format unique feature 
identifier 

 

 
 

n. The distance matrix will be saved under the file name you choose and 
a table will appear in your ArcView window as a copy of that dbf file 
that contains the distance between the different point features. 

o. A more robust file is created if we Export the ArcView table to a 
delimited text file and use this in Excel (File>Export) 
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3. Using Excel to Analyse the Distance Matrix 

Start Excel and open up the newly created Distance Matrix which shows the distance 
between all patches to all other patches. The following Visual Basic for Applications 
(VBA) sample code should be inserted into the Excel file containing the distance 
matrix values. This code generates a continuous string of distances by transposing the 
distance matrix. The results can be used to generate frequency and cumulative 
frequency histograms to show the distribution of inter-patch distances for each study 
area. Standard Excel statistical analysis can also be performed to calculate average 
inter-patch distances, standard deviations and other numerical estimates of landscape 
connectivity. 

Sub DistanceMatrixProcess() 
' DistanceMatrixProcess Macro 
' Created 21/05/2003 by Andre Zerger 
' Program converts a symmetrical matrix to a continuous string of values 
' for use performing statistical analysis (frequency histograms). 
 
 increment = 0 
 rowOut = 2 
 
'Start with row number 2 and move down the rows in the file 
'For 235 colums, set upper value of r to 235 
 For r = 2 To 235  

'Move along the columns, and increment the starting column 
   'value depending on the row number that is being processed 

 For c = 3 To (235 - increment) 
          Sheets("AllFinal").Select 
          Cells(c + increment, r).Copy 
          Sheets("test").Select 
          Cells(rowOut - 1, 1).Select 
          ActiveSheet.Paste 
         rowOut = rowOut + 1 
    Next c 
    'Decrement the row value along the diagonal matrix for each row incremented 
    'to initialise a new starting row value 
      increment = increment + 1 
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Next r 

End Sub 

 
Using the following macro all the columns in the distance matrix can be sorted, 
thus allowing the calculation of the mean nearest neighbour and the mean of the 5 
nearest neighbours. 

Sub Macro1() 
' Find K Nearest Neighbours 
' Macro developed by Andre Zerger, CSIRO Sustainable Ecosystems 
 
' Macro is used to sort columns in order to find K number of nearest 
' neighbours from a distance matrix 

 
Dim c As Integer 
For c = 2 To 250 
    Sheets("After sorted").Columns(c).Select 
    Selection.sort Key1:=Cells(1, c), Order1:=xlAscending, Header:=xlYes, _ 
        OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom 
Next c 
End Sub 
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4. Appendix  

 
ADDXY.ave 
An Avenue script that adds latitude and longitude coordinates to a Shapefile 
' Name: View.AddXYCoordToFTab 
'  
' Title:  Adds X and Y coordinates of features to Attribute Table 
' 
' Topics:  GeoData 
' 
' Description:  Adds two new fields, named X-coord and Y-coord, to the table 
' of the first active theme in the TOC and fills the respective fields with 
' the X,Y coordinates of the selected points (or all points if no selection  
' is defined) in a point theme.  If instead the active theme is a polygon  
' theme, then the X,Y coordinates of the polygon centroid are calculated. If  
' the theme is projected, the output coordinates will also be projected. 
' 
' Requires:  An active point or polygon theme. This script does minimal 
' error checking and assumes that there is an active theme.  
' 
' Self:   
' 
' Returns:   
 
theView = av.GetActiveDoc 
'must be global to work in Calc exp below 
_theProjection = theView.GetProjection  
project_flag = _theProjection.IsNull.Not  'true if projected 
theTheme = theView.GetActiveThemes.Get(0) 
 
'Check if point or polygon theme 
if (((theTheme.GetSrcName.GetSubName = "point") or  
    (theTheme.GetSrcName.GetSubName = "polygon")).Not) then 
  MsgBox.Info("Active theme must be polygon or point theme","") 
  exit 
end   
 
'get the theme table and current edit state 
theFTab = theTheme.GetFTab 
theFields = theFTab.GetFields 
edit_state = theFTab.IsEditable 
 
'make sure table is editable and that fields can be added 
if (theFtab.CanEdit) then 
  theFTab.SetEditable(true) 
  if ((theFTab.CanAddFields).Not) then 
    MsgBox.Info("Can't add fields to the table."+NL+"Check write permission.", 
    "Can't add X,Y coordinates") 
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    exit 
  end 
else 
  MsgBox.Info("Can't modify the feature table."+NL+ 
  "Check write permission.","Can't add X,Y coordinates") 
  exit 
end 
 
'Check if fields named "X-coord" and Y-coord" exist 
x_exists = (theFTab.FindField("X-coord") = NIL).Not 
y_exists = (theFtab.FindField("Y-coord") = NIL).Not 
 
if (x_exists or y_exists) then  
  if (MsgBox.YesNo("Overwrite existing fields?", 
  "X-coord, Y-coord fields already exist", false)) then 
    'if ok to overwrite, delete the fields as they may not be defined 
    'as required by this script (eg., created from another script). 
    if (x_exists) then 
      theFTab.RemoveFields({theFTab.FindField("X-coord")}) 
    end 
    if (y_exists) then 
      theFTab.RemoveFields({theFTab.FindField("Y-coord")}) 
    end 
  else 
    exit 
  end  'if (MsgBox...) 
end  'if 
 
x = Field.Make ("X-coord",#FIELD_DECIMAL,18,5) 
y = Field.Make ("Y-coord",#FIELD_DECIMAL,18,5) 
theFTab.AddFields({x,y}) 
 
'Get point coordinates or polygon centroid coordinates 
if (theTheme.GetSrcName.GetSubName = "point") then 
  if (project_flag) then 
    'Projection defined 
    theFTab.Calculate("[Shape].ReturnProjected(_theProjection).GetX", x) 
    theFTab.Calculate("[Shape].ReturnProjected(_theProjection).GetY", y) 
  else 
    'No projection defined 
    theFTab.Calculate("[Shape].GetX", x) 
    theFTab.Calculate("[Shape].GetY", y) 
  end  'if 
else  'polygon case 
  if (project_flag) then 
    theFTab.Calculate("[Shape].ReturnCenter.ReturnProjected(_theProjection).GetX", 
x) 
    theFTab.Calculate("[Shape].ReturnCenter.ReturnProjected(_theProjection).GetY", 
y) 
  else 
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    theFTab.Calculate("[Shape].ReturnCenter.GetX", x) 
    theFTab.Calculate("[Shape].ReturnCenter.GetY", y) 
  end  ' if 
end 
 
'Return editing state to pre-script running state 
theFTab.SetEditable(edit_state) 
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Interpolate.ave 
An avenue script that mearure distanced between points and a distance to core area 
surface. 
 
'grid2spots.ave 
'written by mikael elmquist  
theView = av.GetActiveDoc 
 
theThemes={} 
for each ttheme in theView.GetThemes 
  if (ttheme.Is(Gtheme).Not) then 
  see = ttheme.GetFtab.GetClass.GetClassName   
    if (ttheme.GetFtab.findfield("Shape").gettype = #FIELD_SHAPEPOINT) then 
      theThemes.Add(ttheme) 
    end 
  end 
end 
thePointTheme = MsgBox.ChoiceAsString(theThemes,"Select point theme that shall 
get values from the grid theme.","GetGridValue") 
if (thePointTheme = Nil) then 
  exit 
end 
theFtab = thePointTheme.GetFtab 
 
theThemes={} 
if (theFtab.CanEdit) then 
  theFTab.SetEditable(true) 
  if ((theFTab.CanAddFields).Not) then 
    MsgBox.Info("Can't add fields to the table."+NL+"Check write permission.", 
    "Can't add grid values") 
    exit 
  end 
else 
  MsgBox.Info("Can't modify the feature table."+NL+ 
  "Check write permission.","Can't add grid values") 
  exit 
end 
 
 
for each ttheme in theView.GetThemes 
  if (ttheme.Is(Gtheme)) then 
    theThemes.Add(ttheme) 
  end 
end 
theGtheme = MsgBox.ChoiceAsString(theThemes,"Select grid that shall assign 
values to the point theme.","GetGridValue") 
if (theGtheme = Nil) then 
  exit 
end 
theGrid = theGtheme.Clone.GetGrid.Clone 
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thePrj = Prj.MakeNull 
varname = MsgBox.Input( "Enter new Variable Name", "Gridvalue", "add var-name" 
) 
'gridvalueField = Field.Make (varname,#FIELD_LONG,8,0)  
gridvalueField = Field.Make (varname,#FIELD_DECIMAL,10,2) 
theShapeField = theFtab.FindField("shape") 
theFTab.AddFields({gridvalueField}) 
 
 
 
 
 
for each rec in theFtab 
  theValue = theGrid.CellValue(theFtab.returnValue(theShapeField,rec),thePrj) 
  if (theValue<>Nil) then 
    theFtab.setValue(gridvalueField,rec,theValue) 
  end 
end 
 
'************* 
'Reset arcview 
'************* 
theFtab.Flush 
theFtab.Refresh  
av.purgeobjects 
av.ClearStatus 
av.ClearMsg 
 


